*Информация актуальна на начало 2024 г. Мы будем отслеживать ситуацию и обновим материал при изменении ситуации.

Для обновления Moodle до версии 4.2 и новее требуется MySQL 8.0 На виртуальном хостинге Бегет такой возможности нет. Но можно использовать облачную базу данных в ПУ Бегет. Если вы уже обновились до Moodle 4.1 на Бегет и хотите обновляться и далее, то, на данный момент (начало 2024 г) существует только одна возможность – использовать облачную базу данных с MySQL 8.0.

Как это сделать?

В ПУ Бегет на вкладке “Облако” кликните “База данных”:

На данный момент у Бегет действует акция – 3 месяца облачная БД за 1 руб. Если вы не видите этого предложения на скрине выше – попробуйте перейти в ПУ на вкладку MySQL и создать БД оттуда:

Выберите MySQL 8.0 и минимальный тариф, введите своё название базы данных и обязательно проверьте, чтобы база данных вашего Moodle была в списке для бесплатного переноса в облако, нажмите “Создать базу данных”:

Облачная БД будет создана. Перенос БД в облако может занять до трёх дней (обычно меньше).

В это время ваш Moodle будет продолжать работать на старой БД. После переноса БД в облако вам будет нужно прописать параметры подключения к новой БД в файле config.php

Для этого откройте облачную БД и откройте список баз данных:

Выберите вашу БД и нажмите зелёный плюсик (добавить доступ):

В всплывающем окне установите “Единый доступ для различных IP-адресов”, задайте пароль и нажмите “Добавить”:

Вернитесь в облако, в выпадающем списке выберите вашу БД:

Вы увидите параметры для подключения к БД:

В файл-менеджере откройте файл config.php вашего Moodle и пропишите эти данные:

После этого можно проверить работу сайта. Также можете посмотреть в Админке – Сервер – Среда (версии ПО) версию MySQL и другие параметры для обновления:

Если всё в порядке – можно приступать к обновлению Moodle стандартным способом по этой инструкции.